Monday, August 17, 2015

Spine1 and Spine2 Configurations - Arista Spine and Leaf on Virtualbox

Spine1 - configuration

spine1#sh run
! Command: show running-config
! device: spine1 (vEOS, EOS-4.15.0F)
!
! boot system flash:/vEOS-lab.swi
!
transceiver qsfp default-mode 4x10G
!
hostname spine1
!
spanning-tree mode mstp
!
no aaa root
!
username arista privilege 15 secret 5 $1$K3V/gaso$cKa9M9Jx4wYW.E90v3k6C1
!
interface Ethernet1
   no switchport
   ip address 10.180.254.1/30
!
interface Ethernet2
   no switchport
   ip address 10.180.254.5/30
!
interface Ethernet3
   no switchport
   ip address 10.180.254.9/30
!
interface Ethernet4
   no switchport
   ip address 10.180.254.13/30
!
interface Ethernet5
   no switchport
   ip address 10.180.254.17/30
!
interface Ethernet6
   no switchport
   ip address 10.180.254.21/30
!
interface Loopback0
   ip address 10.0.0.251/24
!
interface Management1
   ip address 10.10.10.21/24
!
ip route 0.0.0.0/0 192.168.1.254
!
ip routing
!
router bgp 65000
   maximum-paths 4 ecmp 128
   neighbor 10.180.254.2 remote-as 65101
   neighbor 10.180.254.2 maximum-routes 12000
   neighbor 10.180.254.6 remote-as 65101
   neighbor 10.180.254.6 maximum-routes 12000
   neighbor 10.180.254.10 remote-as 65102
   neighbor 10.180.254.10 maximum-routes 12000
   neighbor 10.180.254.14 remote-as 65102
   neighbor 10.180.254.14 maximum-routes 12000
   neighbor 10.180.254.18 remote-as 65103
   neighbor 10.180.254.18 maximum-routes 12000
   neighbor 10.180.254.22 remote-as 65103
   neighbor 10.180.254.22 maximum-routes 12000
   network 10.0.0.251/32
   network 10.180.254.0/24
!
!
end

spine1#sh ip route

VRF name: default
Codes: C - connected, S - static, K - kernel,
       O - OSPF, IA - OSPF inter area, E1 - OSPF external type 1,
       E2 - OSPF external type 2, N1 - OSPF NSSA external type 1,
       N2 - OSPF NSSA external type2, B I - iBGP, B E - eBGP,
       R - RIP, I - ISIS, A B - BGP Aggregate, A O - OSPF Summary,
       NG - Nexthop Group Static Route

Gateway of last resort:
 S      0.0.0.0/0 [1/0] via 10.180.254.18, Ethernet5
                        via 10.180.254.22, Ethernet6

 B E    10.0.0.1/32 [200/0] via 10.180.254.2, Ethernet1
                            via 10.180.254.6, Ethernet2
 B E    10.0.0.2/32 [200/0] via 10.180.254.2, Ethernet1
                            via 10.180.254.6, Ethernet2
 B E    10.0.0.3/32 [200/0] via 10.180.254.10, Ethernet3
 B E    10.0.0.4/32 [200/0] via 10.180.254.14, Ethernet4
 B E    10.0.0.5/32 [200/0] via 10.180.254.18, Ethernet5
                            via 10.180.254.22, Ethernet6
 B E    10.0.0.6/32 [200/0] via 10.180.254.18, Ethernet5
                            via 10.180.254.22, Ethernet6
 C      10.0.0.0/24 is directly connected, Loopback0
 C      10.10.10.0/24 is directly connected, Management1
 C      10.180.254.0/30 is directly connected, Ethernet1
 C      10.180.254.4/30 is directly connected, Ethernet2
 C      10.180.254.8/30 is directly connected, Ethernet3
 C      10.180.254.12/30 is directly connected, Ethernet4
 C      10.180.254.16/30 is directly connected, Ethernet5
 C      10.180.254.20/30 is directly connected, Ethernet6
 B E    172.16.1.0/24 [200/0] via 10.180.254.2, Ethernet1
                              via 10.180.254.6, Ethernet2
 B E    172.16.2.0/24 [200/0] via 10.180.254.10, Ethernet3
                              via 10.180.254.14, Ethernet4
 B E    172.16.3.0/24 [200/0] via 10.180.254.18, Ethernet5
                              via 10.180.254.22, Ethernet6
 B E    192.168.1.0/24 [200/0] via 10.180.254.18, Ethernet5

                               via 10.180.254.22, Ethernet6

Spine2 - configuration

spine2#sh run
! Command: show running-config
! device: spine2 (vEOS, EOS-4.15.0F)
!
! boot system flash:/vEOS-lab.swi
!
transceiver qsfp default-mode 4x10G
!
hostname spine2
!
spanning-tree mode mstp
!
no aaa root
!
username arista privilege 15 secret 5 $1$pg3sCc5I$VQihCe2v65NMb6MuCLTI60
!
interface Ethernet1
   no switchport
   ip address 10.180.254.129/30
!
interface Ethernet2
   no switchport
   ip address 10.180.254.133/30
!
interface Ethernet3
   no switchport
   ip address 10.180.254.137/30
!
interface Ethernet4
   no switchport
   ip address 10.180.254.141/30
!
interface Ethernet5
   no switchport
   ip address 10.180.254.145/30
!
interface Ethernet6
   no switchport
   ip address 10.180.254.149/30
!
interface Loopback0
   ip address 10.0.0.2/32
!
interface Management1
   ip address 10.10.10.22/24
!
ip route 0.0.0.0/0 192.168.1.254
!
ip routing
!
router bgp 65000
   maximum-paths 4 ecmp 128
   neighbor 10.180.254.130 remote-as 65101
   neighbor 10.180.254.130 maximum-routes 12000
   neighbor 10.180.254.134 remote-as 65101
   neighbor 10.180.254.134 maximum-routes 12000
   neighbor 10.180.254.138 remote-as 65102
   neighbor 10.180.254.138 maximum-routes 12000
   neighbor 10.180.254.142 remote-as 65102
   neighbor 10.180.254.142 maximum-routes 12000
   neighbor 10.180.254.146 remote-as 65103
   neighbor 10.180.254.146 maximum-routes 12000
   neighbor 10.180.254.150 remote-as 65103
   neighbor 10.180.254.150 maximum-routes 12000
   network 10.0.0.252/32
   network 10.180.254.0/24
!
!
end

spine2# sh ip route

VRF name: default
Codes: C - connected, S - static, K - kernel,
       O - OSPF, IA - OSPF inter area, E1 - OSPF external type 1,
       E2 - OSPF external type 2, N1 - OSPF NSSA external type 1,
       N2 - OSPF NSSA external type2, B I - iBGP, B E - eBGP,
       R - RIP, I - ISIS, A B - BGP Aggregate, A O - OSPF Summary,
       NG - Nexthop Group Static Route

Gateway of last resort:
 S      0.0.0.0/0 [1/0] via 10.180.254.146, Ethernet5
                        via 10.180.254.150, Ethernet6

 B E    10.0.0.1/32 [200/0] via 10.180.254.130, Ethernet1
                            via 10.180.254.134, Ethernet2
 C      10.0.0.2/32 is directly connected, Loopback0
 B E    10.0.0.3/32 [200/0] via 10.180.254.138, Ethernet3
 B E    10.0.0.4/32 [200/0] via 10.180.254.142, Ethernet4
 B E    10.0.0.5/32 [200/0] via 10.180.254.146, Ethernet5
                            via 10.180.254.150, Ethernet6
 B E    10.0.0.6/32 [200/0] via 10.180.254.146, Ethernet5
                            via 10.180.254.150, Ethernet6
 C      10.10.10.0/24 is directly connected, Management1
 C      10.180.254.128/30 is directly connected, Ethernet1
 C      10.180.254.132/30 is directly connected, Ethernet2
 C      10.180.254.136/30 is directly connected, Ethernet3
 C      10.180.254.140/30 is directly connected, Ethernet4
 C      10.180.254.144/30 is directly connected, Ethernet5
 C      10.180.254.148/30 is directly connected, Ethernet6
 B E    172.16.1.0/24 [200/0] via 10.180.254.130, Ethernet1
                              via 10.180.254.134, Ethernet2
 B E    172.16.2.0/24 [200/0] via 10.180.254.138, Ethernet3
                              via 10.180.254.142, Ethernet4
 B E    172.16.3.0/24 [200/0] via 10.180.254.146, Ethernet5
                              via 10.180.254.150, Ethernet6
 B E    192.168.1.0/24 [200/0] via 10.180.254.146, Ethernet5
                               via 10.180.254.150, Ethernet6

No comments:

Post a Comment