Monday, August 17, 2015

Leaf Switch Configurations - Arista Spine and Leaf on Virtualbox

Switch 1 - Configuration

leaf1-sw01>en
leaf1-sw01#sh run
! Command: show running-config
! device: leaf1-sw01 (vEOS, EOS-4.15.0F)
!
! boot system flash:/vEOS-lab.swi
!
transceiver qsfp default-mode 4x10G
!
hostname leaf1-sw01
!
spanning-tree mode mstp
!
no aaa root
!
username arista privilege 15 secret 5 $1$x5GKrbKk$azBM4Wlv3TzOQjcjeXOHJ.
!
vlan 101
!
vlan 2047
   trunk group mlagL1-L2
!
interface Port-Channel1
   switchport mode trunk
   switchport trunk group mlagL1-L2
!
interface Ethernet1
   no switchport
   ip address 10.180.254.2/30
!
interface Ethernet2
   no switchport
   ip address 10.180.254.130/30
!
interface Ethernet3
   channel-group 1 mode active
!
interface Ethernet4
   channel-group 1 mode active
!
interface Ethernet5
   switchport access vlan 101
!
interface Loopback0
   ip address 10.0.0.1/32
!
interface Management1
   ip address 10.10.10.31/24
!
interface Vlan101
   ip address 172.16.1.252/24
   ip virtual-router address 172.16.1.254
!
interface Vlan2047
   ip address 10.180.254.225/30
!
ip route 0.0.0.0/0 192.168.1.254
!
ip routing
!
mlag configuration
   domain-id mlagL1-L2
   local-interface Vlan2047
   peer-address 10.180.254.226
   peer-link Port-Channel1
!
router bgp 65101
   maximum-paths 4 ecmp 128
   neighbor 10.180.254.1 remote-as 65000
   neighbor 10.180.254.1 maximum-routes 12000
   neighbor 10.180.254.129 remote-as 65000
   neighbor 10.180.254.129 maximum-routes 12000
   neighbor 172.16.1.253 remote-as 65101
   neighbor 172.16.1.253 maximum-routes 12000
   network 10.0.0.1/32
   network 10.180.254.0/24
   network 172.16.1.0/24
!
!
end
leaf1-sw01#sh ip route

VRF name: default
Codes: C - connected, S - static, K - kernel,
       O - OSPF, IA - OSPF inter area, E1 - OSPF external type 1,
       E2 - OSPF external type 2, N1 - OSPF NSSA external type 1,
       N2 - OSPF NSSA external type2, B I - iBGP, B E - eBGP,
       R - RIP, I - ISIS, A B - BGP Aggregate, A O - OSPF Summary,
       NG - Nexthop Group Static Route

Gateway of last resort:
 S      0.0.0.0/0 [1/0] via 10.180.254.1, Ethernet1
                        via 10.180.254.129, Ethernet2

 C      10.0.0.1/32 is directly connected, Loopback0
 B I    10.0.0.2/32 [200/0] via 172.16.1.253, Vlan101
 B E    10.0.0.3/32 [200/0] via 10.180.254.1, Ethernet1
                            via 10.180.254.129, Ethernet2
 B E    10.0.0.4/32 [200/0] via 10.180.254.1, Ethernet1
                            via 10.180.254.129, Ethernet2
 B E    10.0.0.5/32 [200/0] via 10.180.254.1, Ethernet1
                            via 10.180.254.129, Ethernet2
 B E    10.0.0.6/32 [200/0] via 10.180.254.1, Ethernet1
                            via 10.180.254.129, Ethernet2
 C      10.10.10.0/24 is directly connected, Management1
 C      10.180.254.0/30 is directly connected, Ethernet1
 C      10.180.254.128/30 is directly connected, Ethernet2
 C      10.180.254.224/30 is directly connected, Vlan2047
 C      172.16.1.0/24 is directly connected, Vlan101
 B E    172.16.2.0/24 [200/0] via 10.180.254.1, Ethernet1
                              via 10.180.254.129, Ethernet2
 B E    172.16.3.0/24 [200/0] via 10.180.254.1, Ethernet1
                              via 10.180.254.129, Ethernet2
 B E    192.168.1.0/24 [200/0] via 10.180.254.1, Ethernet1
                               via 10.180.254.129, Ethernet2


leaf1-sw01#

Switch 2 - Configuration

leaf1-sw02#sh run
! Command: show running-config
! device: leaf1-sw02 (vEOS, EOS-4.15.0F)
!
! boot system flash:/vEOS-lab.swi
!
transceiver qsfp default-mode 4x10G
!
hostname leaf1-sw02
!
spanning-tree mode mstp
!
no aaa root
!
username arista privilege 15 secret 5 $1$dgmrUK3G$GBhRaYnIvOzIOdgozc9Kb.
!
vlan 101
!
vlan 2047
   trunk group mlagL1-L2
!
interface Port-Channel1
   switchport mode trunk
   switchport trunk group mlagL1-L2
!
interface Ethernet1
   no switchport
   ip address 10.180.254.6/30
!
interface Ethernet2
   no switchport
   ip address 10.180.254.134/30
!
interface Ethernet3
   channel-group 1 mode active
!
interface Ethernet4
   channel-group 1 mode active
!
interface Ethernet5
   switchport access vlan 101
!
interface Loopback0
   ip address 10.0.0.2/32
!
interface Management1
   ip address 10.10.10.32/24
!
interface Vlan101
   ip address 172.16.1.253/24
   ip virtual-router address 172.16.1.254
!
interface Vlan2047
   ip address 10.180.254.226/30
!
ip route 0.0.0.0/0 192.168.1.254
!
ip routing
!
mlag configuration
   domain-id mlagL1-L2
   local-interface Vlan2047
   peer-address 10.180.254.225
   peer-link Port-Channel1
!
router bgp 65101
   maximum-paths 4 ecmp 128
   neighbor 10.180.254.5 remote-as 65000
   neighbor 10.180.254.5 maximum-routes 12000
   neighbor 10.180.254.133 remote-as 65000
   neighbor 10.180.254.133 maximum-routes 12000
   neighbor 172.16.1.252 remote-as 65101
   neighbor 172.16.1.252 maximum-routes 12000
   network 10.0.0.2/32
   network 10.180.254.0/24
   network 172.16.1.0/24
!
!
end
leaf1-sw02# sh ip route

VRF name: default
Codes: C - connected, S - static, K - kernel,
       O - OSPF, IA - OSPF inter area, E1 - OSPF external type 1,
       E2 - OSPF external type 2, N1 - OSPF NSSA external type 1,
       N2 - OSPF NSSA external type2, B I - iBGP, B E - eBGP,
       R - RIP, I - ISIS, A B - BGP Aggregate, A O - OSPF Summary,
       NG - Nexthop Group Static Route

Gateway of last resort:
 S      0.0.0.0/0 [1/0] via 10.180.254.5, Ethernet1
                        via 10.180.254.133, Ethernet2

 B I    10.0.0.1/32 [200/0] via 172.16.1.252, Vlan101
 C      10.0.0.2/32 is directly connected, Loopback0
 B E    10.0.0.3/32 [200/0] via 10.180.254.5, Ethernet1
                            via 10.180.254.133, Ethernet2
 B E    10.0.0.4/32 [200/0] via 10.180.254.5, Ethernet1
                            via 10.180.254.133, Ethernet2
 B E    10.0.0.5/32 [200/0] via 10.180.254.5, Ethernet1
                            via 10.180.254.133, Ethernet2
 B E    10.0.0.6/32 [200/0] via 10.180.254.5, Ethernet1
                            via 10.180.254.133, Ethernet2
 C      10.10.10.0/24 is directly connected, Management1
 C      10.180.254.4/30 is directly connected, Ethernet1
 C      10.180.254.132/30 is directly connected, Ethernet2
 C      10.180.254.224/30 is directly connected, Vlan2047
 C      172.16.1.0/24 is directly connected, Vlan101
 B E    172.16.2.0/24 [200/0] via 10.180.254.5, Ethernet1
                              via 10.180.254.133, Ethernet2
 B E    172.16.3.0/24 [200/0] via 10.180.254.5, Ethernet1
                              via 10.180.254.133, Ethernet2
 B E    192.168.1.0/24 [200/0] via 10.180.254.5, Ethernet1
                               via 10.180.254.133, Ethernet2

leaf1-sw02#

Switch 3 - configuration

leaf2-sw03>en
leaf2-sw03#sh run
! Command: show running-config
! device: leaf2-sw03 (vEOS, EOS-4.15.0F)
!
! boot system flash:/vEOS-lab.swi
!
transceiver qsfp default-mode 4x10G
!
hostname leaf2-sw03
!
spanning-tree mode mstp
!
no aaa root
!
username arista privilege 15 secret 5 $1$PQtScGLc$3eEJepRVOUEahC.wNveqG/
!
vlan 102
!
vlan 2048
   trunk group mlagL3-L4
!
interface Port-Channel1
   switchport mode trunk
   switchport trunk group mlagL3-L4
!
interface Ethernet1
   no switchport
   ip address 10.180.254.10/30
!
interface Ethernet2
   no switchport
   ip address 10.180.254.138/30
!
interface Ethernet3
   channel-group 1 mode active
!
interface Ethernet4
   channel-group 1 mode active
!
interface Ethernet5
   switchport access vlan 102
!
interface Loopback0
   ip address 10.0.0.3/32
!
interface Management1
   ip address 10.10.10.33/24
!
interface Vlan102
   ip address 172.16.2.252/24
   ip virtual-router address 172.16.2.254
!
interface Vlan2048
   ip address 10.180.254.229/30
!
ip route 0.0.0.0/0 192.168.1.254
!
ip routing
!
mlag configuration
   domain-id mlagL3-L4
   local-interface Vlan2048
   peer-address 10.180.254.230
   peer-link Port-Channel1
!
router bgp 65102
   maximum-paths 4 ecmp 128
   neighbor 10.180.254.9 remote-as 65000
   neighbor 10.180.254.9 maximum-routes 12000
   neighbor 10.180.254.137 remote-as 65000
   neighbor 10.180.254.137 maximum-routes 12000
   neighbor 172.16.2.253 remote-as 65102
   neighbor 172.16.2.253 maximum-routes 12000
   network 10.0.0.3/32
   network 10.180.254.0/24
   network 172.16.2.0/24
!
!
end
leaf2-sw03#sh ip route

VRF name: default
Codes: C - connected, S - static, K - kernel,
       O - OSPF, IA - OSPF inter area, E1 - OSPF external type 1,
       E2 - OSPF external type 2, N1 - OSPF NSSA external type 1,
       N2 - OSPF NSSA external type2, B I - iBGP, B E - eBGP,
       R - RIP, I - ISIS, A B - BGP Aggregate, A O - OSPF Summary,
       NG - Nexthop Group Static Route

Gateway of last resort:
 S      0.0.0.0/0 [1/0] via 10.180.254.9, Ethernet1
                        via 10.180.254.137, Ethernet2

 B E    10.0.0.1/32 [200/0] via 10.180.254.9, Ethernet1
                            via 10.180.254.137, Ethernet2
 B E    10.0.0.2/32 [200/0] via 10.180.254.9, Ethernet1
 C      10.0.0.3/32 is directly connected, Loopback0
 B E    10.0.0.5/32 [200/0] via 10.180.254.9, Ethernet1
                            via 10.180.254.137, Ethernet2
 B E    10.0.0.6/32 [200/0] via 10.180.254.9, Ethernet1
                            via 10.180.254.137, Ethernet2
 C      10.10.10.0/24 is directly connected, Management1
 C      10.180.254.8/30 is directly connected, Ethernet1
 C      10.180.254.136/30 is directly connected, Ethernet2
 C      10.180.254.228/30 is directly connected, Vlan2048
 B E    172.16.1.0/24 [200/0] via 10.180.254.9, Ethernet1
                              via 10.180.254.137, Ethernet2
 C      172.16.2.0/24 is directly connected, Vlan102
 B E    172.16.3.0/24 [200/0] via 10.180.254.9, Ethernet1
                              via 10.180.254.137, Ethernet2
 B E    192.168.1.0/24 [200/0] via 10.180.254.9, Ethernet1
                               via 10.180.254.137, Ethernet2

leaf2-sw03#

Switch4 - configuration

leaf2-sw04>en
leaf2-sw04#sh run
! Command: show running-config
! device: leaf2-sw04 (vEOS, EOS-4.15.0F)
!
! boot system flash:/vEOS-lab.swi
!
transceiver qsfp default-mode 4x10G
!
hostname leaf2-sw04
!
spanning-tree mode mstp
!
no aaa root
!
username arista privilege 15 secret 5 $1$w/eAcrc6$V//ELJ..C40cf7I1kYpfH1
!
vlan 102-103
!
vlan 2048
   trunk group mlagL3-L4
!
interface Port-Channel1
   switchport mode trunk
   switchport trunk group mlagL3-L4
!
interface Ethernet1
   no switchport
   ip address 10.180.254.14/30
!
interface Ethernet2
   no switchport
   ip address 10.180.254.142/30
!
interface Ethernet3
   channel-group 1 mode active
!
interface Ethernet4
   channel-group 1 mode active
!
interface Ethernet5
   switchport access vlan 102
!
interface Loopback0
   ip address 10.0.0.4/32
!
interface Management1
   ip address 10.10.10.34/24
!
interface Vlan103
   ip address 172.16.2.253/24
   ip virtual-router address 172.16.2.254
!
interface Vlan2048
   ip address 10.180.254.230/30
!
ip route 0.0.0.0/0 192.168.1.254
!
ip routing
!
mlag configuration
   domain-id mlagL3-L4
   local-interface Vlan2048
   peer-address 10.180.254.229
   peer-link Port-Channel1
!
router bgp 65102
   maximum-paths 4 ecmp 128
   neighbor 10.180.254.13 remote-as 65000
   neighbor 10.180.254.13 maximum-routes 12000
   neighbor 10.180.254.141 remote-as 65000
   neighbor 10.180.254.141 maximum-routes 12000
   neighbor 172.16.2.252 remote-as 65102
   neighbor 172.16.2.252 maximum-routes 12000
   network 10.0.0.4/32
   network 10.180.254.0/24
   network 172.16.2.0/24
!
!
end
leaf2-sw04# sh ip route

VRF name: default
Codes: C - connected, S - static, K - kernel,
       O - OSPF, IA - OSPF inter area, E1 - OSPF external type 1,
       E2 - OSPF external type 2, N1 - OSPF NSSA external type 1,
       N2 - OSPF NSSA external type2, B I - iBGP, B E - eBGP,
       R - RIP, I - ISIS, A B - BGP Aggregate, A O - OSPF Summary,
       NG - Nexthop Group Static Route

Gateway of last resort:
 S      0.0.0.0/0 [1/0] via 10.180.254.13, Ethernet1
                        via 10.180.254.141, Ethernet2

 B E    10.0.0.1/32 [200/0] via 10.180.254.13, Ethernet1
                            via 10.180.254.141, Ethernet2
 B E    10.0.0.2/32 [200/0] via 10.180.254.13, Ethernet1
 C      10.0.0.4/32 is directly connected, Loopback0
 B E    10.0.0.5/32 [200/0] via 10.180.254.13, Ethernet1
                            via 10.180.254.141, Ethernet2
 B E    10.0.0.6/32 [200/0] via 10.180.254.13, Ethernet1
                            via 10.180.254.141, Ethernet2
 C      10.10.10.0/24 is directly connected, Management1
 C      10.180.254.12/30 is directly connected, Ethernet1
 C      10.180.254.140/30 is directly connected, Ethernet2
 C      10.180.254.228/30 is directly connected, Vlan2048
 B E    172.16.1.0/24 [200/0] via 10.180.254.13, Ethernet1
                              via 10.180.254.141, Ethernet2
 C      172.16.2.0/24 is directly connected, Vlan103
 B E    172.16.3.0/24 [200/0] via 10.180.254.13, Ethernet1
                              via 10.180.254.141, Ethernet2
 B E    192.168.1.0/24 [200/0] via 10.180.254.13, Ethernet1
                               via 10.180.254.141, Ethernet2

leaf2-sw04#

Switch5 - configuration

leaf3-sw05#sh run
! Command: show running-config
! device: leaf3-sw05 (vEOS, EOS-4.15.0F)
!
! boot system flash:/vEOS-lab.swi
!
transceiver qsfp default-mode 4x10G
!
hostname leaf3-sw05
!
spanning-tree mode mstp
!
no aaa root
!
username arista privilege 15 secret 5 $1$lXq5jGZ7$dKqbUEZ4amFlNDjwOb40k.
!
vlan 103
!
vlan 2049
   trunk group mlagL5-L6
!
interface Port-Channel1
   switchport mode trunk
   switchport trunk group mlagL5-L6
!
interface Ethernet1
   no switchport
   ip address 10.180.254.18/30
!
interface Ethernet2
   no switchport
   ip address 10.180.254.146/30
!
interface Ethernet3
   channel-group 1 mode active
!
interface Ethernet4
   channel-group 1 mode active
!
interface Ethernet5
   switchport access vlan 103
!
interface Ethernet6
!
interface Loopback0
   ip address 10.0.0.5/32
!
interface Management1
   ip address 10.10.10.35/24
!
interface Vlan103
   ip address 172.16.3.252/24
   ip virtual-router address 172.16.3.254
!
interface Vlan2049
   ip address 10.180.254.233/30
!
ip route 0.0.0.0/0 192.168.1.254
!
ip routing
!
mlag configuration
   domain-id mlagL5-L6
   local-interface Vlan2049
   peer-address 10.180.254.234
   peer-link Port-Channel1
!
router bgp 65103
   maximum-paths 4 ecmp 128
   neighbor 10.180.254.17 remote-as 65000
   neighbor 10.180.254.17 maximum-routes 12000
   neighbor 10.180.254.145 remote-as 65000
   neighbor 10.180.254.145 maximum-routes 12000
   neighbor 172.16.3.253 remote-as 65103
   neighbor 172.16.3.253 maximum-routes 12000
   network 10.0.0.5/32
   network 10.180.254.0/24
   network 172.16.3.0/24
!
!
end
leaf3-sw05#sh ip route

VRF name: default
Codes: C - connected, S - static, K - kernel,
       O - OSPF, IA - OSPF inter area, E1 - OSPF external type 1,
       E2 - OSPF external type 2, N1 - OSPF NSSA external type 1,
       N2 - OSPF NSSA external type2, B I - iBGP, B E - eBGP,
       R - RIP, I - ISIS, A B - BGP Aggregate, A O - OSPF Summary,
       NG - Nexthop Group Static Route

Gateway of last resort:
 S      0.0.0.0/0 [1/0] via 172.16.3.253, Vlan103

 B E    10.0.0.1/32 [200/0] via 10.180.254.17, Ethernet1
                            via 10.180.254.145, Ethernet2
 B E    10.0.0.2/32 [200/0] via 10.180.254.17, Ethernet1
 B E    10.0.0.3/32 [200/0] via 10.180.254.17, Ethernet1
                            via 10.180.254.145, Ethernet2
 B E    10.0.0.4/32 [200/0] via 10.180.254.17, Ethernet1
                            via 10.180.254.145, Ethernet2
 C      10.0.0.5/32 is directly connected, Loopback0
 B I    10.0.0.6/32 [200/0] via 172.16.3.253, Vlan103
 C      10.10.10.0/24 is directly connected, Management1
 C      10.180.254.16/30 is directly connected, Ethernet1
 C      10.180.254.144/30 is directly connected, Ethernet2
 C      10.180.254.232/30 is directly connected, Vlan2049
 B E    172.16.1.0/24 [200/0] via 10.180.254.17, Ethernet1
                              via 10.180.254.145, Ethernet2
 B E    172.16.2.0/24 [200/0] via 10.180.254.17, Ethernet1
                              via 10.180.254.145, Ethernet2
 C      172.16.3.0/24 is directly connected, Vlan103
 B I    192.168.1.0/24 [200/0] via 172.16.3.253, Vlan103

leaf3-sw05#

Switch6 - configuration

leaf3-sw06>en
leaf3-sw06#sh run
! Command: show running-config
! device: leaf3-sw06 (vEOS, EOS-4.15.0F)
!
! boot system flash:/vEOS-lab.swi
!
transceiver qsfp default-mode 4x10G
!
hostname leaf3-sw06
!
spanning-tree mode mstp
!
no aaa root
!
username arista privilege 15 secret 5 $1$9CoSDfo7$P9IyaxO7Ortb6FBkh93Rc/
!
vlan 103
!
vlan 2049
   trunk group mlagL5-L6
!
interface Port-Channel1
   switchport mode trunk
   switchport trunk group mlagL5-L6
!
interface Ethernet1
   no switchport
   ip address 10.180.254.22/30
!
interface Ethernet2
   no switchport
   ip address 10.180.254.150/30
!
interface Ethernet3
   channel-group 1 mode active
!
interface Ethernet4
   channel-group 1 mode active
!
interface Ethernet5
   switchport access vlan 103
!
interface Ethernet6
!
interface Loopback0
   ip address 10.0.0.6/32
!
interface Management1
   ip address 10.10.10.36/24
!
interface Vlan1
   ip address 192.168.1.2/24
!
interface Vlan103
   ip address 172.16.3.253/24
   ip virtual-router address 172.16.3.254
!
interface Vlan2049
   ip address 10.180.254.234/30
!
ip route 0.0.0.0/0 Ethernet6
ip route 0.0.0.0/0 192.168.1.254
!
ip routing
!
mlag configuration
   domain-id mlagL5-L6
   local-interface Vlan2049
   peer-address 10.180.254.233
   peer-link Port-Channel1
!
router bgp 65103
   maximum-paths 4 ecmp 128
   neighbor 10.180.254.21 remote-as 65000
   neighbor 10.180.254.21 maximum-routes 12000
   neighbor 10.180.254.149 remote-as 65000
   neighbor 10.180.254.149 maximum-routes 12000
   neighbor 172.16.3.252 remote-as 65103
   neighbor 172.16.3.252 maximum-routes 12000
   network 10.0.0.6/32
   network 10.180.254.0/24
   network 172.16.3.0/24
   network 192.168.1.0/24
!
!
end
leaf3-sw06# sh ip route

VRF name: default
Codes: C - connected, S - static, K - kernel,
       O - OSPF, IA - OSPF inter area, E1 - OSPF external type 1,
       E2 - OSPF external type 2, N1 - OSPF NSSA external type 1,
       N2 - OSPF NSSA external type2, B I - iBGP, B E - eBGP,
       R - RIP, I - ISIS, A B - BGP Aggregate, A O - OSPF Summary,
       NG - Nexthop Group Static Route

Gateway of last resort:
 S      0.0.0.0/0 [1/0] via 192.168.1.254, Vlan1

 B E    10.0.0.1/32 [200/0] via 10.180.254.21, Ethernet1
                            via 10.180.254.149, Ethernet2
 B E    10.0.0.2/32 [200/0] via 10.180.254.21, Ethernet1
 B E    10.0.0.3/32 [200/0] via 10.180.254.21, Ethernet1
                            via 10.180.254.149, Ethernet2
 B E    10.0.0.4/32 [200/0] via 10.180.254.21, Ethernet1
                            via 10.180.254.149, Ethernet2
 B I    10.0.0.5/32 [200/0] via 172.16.3.252, Vlan103
 C      10.0.0.6/32 is directly connected, Loopback0
 C      10.10.10.0/24 is directly connected, Management1
 C      10.180.254.20/30 is directly connected, Ethernet1
 C      10.180.254.148/30 is directly connected, Ethernet2
 C      10.180.254.232/30 is directly connected, Vlan2049
 B E    172.16.1.0/24 [200/0] via 10.180.254.21, Ethernet1
                              via 10.180.254.149, Ethernet2
 B E    172.16.2.0/24 [200/0] via 10.180.254.21, Ethernet1
                              via 10.180.254.149, Ethernet2
 C      172.16.3.0/24 is directly connected, Vlan103
 C      192.168.1.0/24 is directly connected, Vlan1

leaf3-sw06#

No comments:

Post a Comment